Benvenuto!

RH è il posto ideale per ogni retrogiocatore che si rispetti. Se vuoi farne parte e poter commentare gli articoli o partecipare alle discussioni del forum, registrati.

Registrati

annuncio

Comprimi
Ancora nessun annuncio.
Commodore 64 con spazzatura al boot e black screen

Commodore 64 con spazzatura al boot e black screen

Comprimi
X
 
  • Filtro
  • Ora
  • Visualizza
Elimina tutto
nuovi messaggi

  • Hyuma
    ha risposto
    ciao, io ho usato anche questo per fare il calcolo di quale RAM fosse danneggiata:

    http://blog.worldofjani.com/?p=158

    prova a rimuovere anche i CIA1 e CIA2 per vedere se cambia qualcosa.
    Però li secondo me è da verificare la PLA e qualche RAM.

    Lascia un commento:


  • pippo92
    ha risposto
    Prego,hai già fatto la prova con il dito sopra le ram per scoprire se qualcuna scalda più del normale cosi da sostituirla, anche se non è detto che se non scalda vuol dire che non sia guasta comunque conviene provare. Si ho consultato anche io il sito ed effettivamente i punti esclamativi indicano il guasto di U21 e U22 o altre ram. Quindi se hai a disposizione i componenti e tanta pazienza metti dei zoccoli e li sostituisci sperando che risolvi.

    Lascia un commento:


  • ivo333
    ha risposto
    Grazie della risposta!
    Purtroppo non ho la cartuccia di diagnostica. Ho a disposizione un normale tester, un logic probe e ovviamente le varie guide che sto consultando online. Ci sarebbe pure il software Soundcard Scope, che mi dicono non funzioni con la scheda del C64 che gira ad 1 Mhz. Ci vorrebbe un oscilloscopio con almeno 20 Mhz.

    Al momento ho risolto il black screen scollegando il chip SID.
    Sono rimaste le schermate di start con scritte tipo "syntax error" oppure lo schermo vuoto con un paio di "!" qua e là. O ancora lo schermo pieno di "N". Se la prima è riconducibile ad un errore nel bit "0", non saprei come interpretare la seconda.
    Consultando "The Pictorial C64 FG" ho trovato che la "!" è associata ad un errore di U21.
    Alle volte compare pure il cursore e la tastiera funziona, riesco a scrivere ma non ad eseguire comandi tipo PRINT.

    Ho misurato con il tester il voltaggio delle RAM, risulta diverso leggermente tra loro, ma soprattutto cambia considerevolmente da schermata a schermata, si passa da 1,2volt a 3volt e oltre a seconda di cosa compare all'avvio.

    Lascia un commento:


  • pippo92
    ha risposto
    Ciao, allora senza una cartuccia "dead test" è un pò complicato trovare la causa, comunque dalla schermata che visualizzo sicuramente sono da controllare le ram ma il principale indiziato penso che sia la Cpu-U7 MOS 6510 o altro come qualche Ic della logica ol il PLA.

    Lascia un commento:


  • ivo333
    ha iniziato la discussione Commodore 64 con spazzatura al boot e black screen

    Commodore 64 con spazzatura al boot e black screen

    Qualche consiglio su come ripararlo?
Sto operando...
X